use strict;
my $str = '+++++\' \'asd\'\'\'\'\'\'\'\'\'\'\'sdsdsdsdsdsddddddddddddddddddddddddddddddddd\'\'\'\' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf\'\'sssdssssssssssssssssssssssssss\'\'\'\'\'sd\'\'\'\'\'\'\' d
\'\'\'\'\'\'\'\'\'\'\'\'\'sd\'\' sfdasdasd dsa sdk\' d\' ddaf 3f0 sc\'ddd\'_0_c_8_\'\' 9 9d \'c\'ddd\'_0_csdf
as 0a
_0_c_sdf8_
K9Jk0-asd
L________f______________3j
]\\[][]\\[';
my $regex = qr/(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}