// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}").unwrap();
let string = "+++++' 'asd'''''''''''sdsdsdsdsdsddddddddddddddddddddddddddddddddd'''' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf''sssdssssssssssssssssssssssssss'''''sd''''''' d
'''''''''''''sd'' sfdasdasd dsa sdk' d' ddaf 3f0 sc'ddd'_0_c_8_'' 9 9d 'c'ddd'_0_csdf
as 0a
_0_c_sdf8_
K9Jk0-asd
L________f______________3j
]\\[][]\\[";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}