import Foundation
let pattern = #"(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
+++++' 'asd'''''''''''sdsdsdsdsdsddddddddddddddddddddddddddddddddd'''' fdfdfdfdfddfdfdfdfdfdfdfdfdfdfdfdf''sssdssssssssssssssssssssssssss'''''sd''''''' d
'''''''''''''sd'' sfdasdasd dsa sdk' d' ddaf 3f0 sc'ddd'_0_c_8_'' 9 9d 'c'ddd'_0_csdf
as 0a
_0_c_sdf8_
K9Jk0-asd
L________f______________3j
]\[][]\[
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}