Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<!\s{1}Jr[.!?]|\s{1}Mr[.!?]|\s{1}Mrs[.!?]|\s{1}Ms[.!?]|\s{1}Dr[.!?]|\s{1}Prof[.!?]|\s{1}Sr[.!?]|\s{1}vs[.!?]|\s{1}etc[.!?]|\s{1}no[.!?])(?<=[.?!])\s+(?=[a-z])
/
i
Input 1
1
New