import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(\\w*)$";
final String string = "http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg";
final String subst = "-150x150.$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}