#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((8|\+7?)[\- ]?)?(\(?\d{3}\)?[\- ]?)?([\d\- ]{7,10})"
Local $sString = "======== local phone" & @CRLF & _
"" & @CRLF & _
"765-43-21" & @CRLF & _
"7654321" & @CRLF & _
"765-4321" & @CRLF & _
"" & @CRLF & _
"======== operator phone" & @CRLF & _
"" & @CRLF & _
"(921) 765-43-21" & @CRLF & _
"(921) 7654321" & @CRLF & _
"(921) 765-4321" & @CRLF & _
"" & @CRLF & _
"(921)765-43-21" & @CRLF & _
"(921)7654321" & @CRLF & _
"(921)765-4321" & @CRLF & _
"" & @CRLF & _
"921765-43-21" & @CRLF & _
"9217654321" & @CRLF & _
"921765-4321" & @CRLF & _
"" & @CRLF & _
"921-765-43-21" & @CRLF & _
"921-7654321" & @CRLF & _
"921-765-4321" & @CRLF & _
"" & @CRLF & _
"======== world phone" & @CRLF & _
"" & @CRLF & _
"+7 (921) 765-43-21" & @CRLF & _
"+7(921) 765-43-21" & @CRLF & _
"+7-(921) 765-43-21" & @CRLF & _
"7 (921) 765-43-21" & @CRLF & _
"7(921) 765-43-21" & @CRLF & _
"8 (921) 765-43-21" & @CRLF & _
"8(921) 765-43-21" & @CRLF & _
"8-(921) 765-43-21" & @CRLF & _
"8 (921) 765-43-21" & @CRLF & _
"8(921) 765-43-21" & @CRLF & _
"8-(921) 765-43-21" & @CRLF & _
"" & @CRLF & _
"+7 9217654321" & @CRLF & _
"+79217654321" & @CRLF & _
"+7-9217654321" & @CRLF & _
"7 9217654321" & @CRLF & _
"79217654321" & @CRLF & _
"7-9217654321" & @CRLF & _
"8 9217654321" & @CRLF & _
"89217654321" & @CRLF & _
"8-9217654321" & @CRLF & _
"8 9217654321" & @CRLF & _
"89217654321" & @CRLF & _
"8-9217654321" & @CRLF & _
"" & @CRLF & _
"======== not found " & @CRLF & _
"" & @CRLF & _
">>>>>>>>> 1. Коржев Артём Борисович 8-921-641-82-15;" & @CRLF & _
"" & @CRLF & _
"======== bad" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0 0 0 0" & @CRLF & _
"333 000" & @CRLF & _
"1 1 1205 1320 321" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"======== разбор" & @CRLF & _
"" & @CRLF & _
" # world phone" & @CRLF & _
" (" & @CRLF & _
" (8|\+?7)" & @CRLF & _
" [\- ]?" & @CRLF & _
" )?" & @CRLF & _
"" & @CRLF & _
" # operator phone" & @CRLF & _
" (" & @CRLF & _
" \(?" & @CRLF & _
" \d{3}" & @CRLF & _
" \)?" & @CRLF & _
" [\- ]?" & @CRLF & _
" )?" & @CRLF & _
"" & @CRLF & _
" # local phone" & @CRLF & _
" [\d\- ]{7,10}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")