$re = '/(\b((?:https?|ftp):\/\/|www\.)([0-9A-Za-z]+\.?)+\b)/';
$str = 'http://www.google.com
www.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);