const regex = /(?:(?:\\+|0{0,2})91(\\s*[\\- ]\\s*)?|[0 ]?)?[789]\\d{9}|(\\d[ -]?){10}\\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:\\\\+|0{0,2})91(\\\\s*[\\\\- ]\\\\s*)?|[0 ]?)?[789]\\\\d{9}|(\\\\d[ -]?){10}\\\\d', 'g')
const str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
5555555555
1 555 555 5555
1-555-555-5555
1.555.555.5555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}