#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:.+\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$"
Local $sString = ""C:\\Users\\username\\C-Sharp\\Project\\12345678_X\\Folder\\56781234_01.itm""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")