import Foundation
let pattern = #"^(?:.+\\*)([0-9]{8})(?:.+)(?:\.)(?:.+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""C:\\Users\\username\\C-Sharp\\Project\\12345678_X\\Folder\\56781234_01.itm""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}