# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"hours\":\s*(\{(?>[^{}]++|(?1))*\})"
test_str = ("\"hours\": {\"Monday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Tuesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Friday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Wednesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Thursday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Sunday\": {\"close\": \"18:00\", \"open\": \"11:00\"}, \"Saturday\": {\"close\": \"19:00\", \"open\": \"10:00\"}}\n"
"{\"storeid: \"Hsdf34\", \"hours\": {\"Monday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Tuesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Friday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Wednesday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Thursday\": {\"close\": \"19:00\", \"open\": \"10:00\"}, \"Sunday\": {\"close\": \"18:00\", \"open\": \"11:00\"}, \"Saturday\": {\"close\": \"19:00\", \"open\": \"10:00\"}}, \"address\": \"1234 Sunset Avenue\"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.