re = /\(\d{3}\)\s*\d{3}[\s.-]?\d{4}\b|\*\d{3,10}|\d{3,10}\*/
str = ' (734) 555 1212
(734) 555.1212
(734) 555-1212
(734) 5551212
(734)5551212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end