const regex = /(?<=moving towards )[^-.]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=moving towards )[^-.]*', '')
const str = `World is moving towards a particular point`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}