$re = '/(?<=moving towards )[^-.]*/';
$str = 'World is moving towards a particular point';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);