use strict;
my $str = 'import stuff
class ITEM1(BaseSerializer):
\'\'\'docstring\'\'\'
profile_id = None
house_id = None
# synopsis = ModelIDListField(source=\'synopsis\', serializer=NotificationSerializer)
class Meta:
\'\'\'docstring\'\'\'
# model = Null
model = ITEM2
fields = (ITEM3)
# write_once_fields = (Null)
write_once_fields = (ITEM4)
required_fields = (ITEM5)
depth = 1
class ITEM1(HouseUserSerializer):
# synopsis = ModelIDListField(source=\'synopsis\')
class Meta:
# model = Null
model = ITEM2
fields = (ITEM3)
required_fields = (ITEM5)
depth = 1';
my $regex = qr/(?s)\nclass\s(.*?)(?=\().*?model\s=\s(.*?)\n.*?(?=fields.*?\((.*?)\)).*?(?=write_once_fields.*?\((.*?)\)).*?(?=required_fields.*?\((.*?)\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}