import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,3}(?:[.,]\\d{3})*(?:[.,]\\d{2})";
final String string = "5\n"
+ "5.00\n"
+ "1,000\n"
+ "1,000,000.99\n"
+ "5,99 (european price)\n"
+ "5.999,99 (european price)\n"
+ "0.11\n"
+ "0.00";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}