using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(?:\.(\d+))?(?:\.(\d+))?(?:([a-z]+))?";
string input = @"select all objects where [verse code='MAT' and chapter='1' and number = '1' GET code, chapter, number] go";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}