$re = '/(?<=gcid)(.*)(?=web)/m';
$str = 'gcid1231231webtest';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);