using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])";
string substitution = @"\n";
string input = @"(13-1)*(12-10)/(21+10)*(14-10)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}