$re = '/\b|(?<=[()])(?=[^\d()])|(?<=[^\d()])(?=[()])/';
$str = '(13-1)*(12-10)/(21+10)*(14-10)';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;