re = /<!-- Begin section -->(?s).*<!-- End section -->/
str = '<!-- Begin section -->Lots of code here<!-- End section -->
<!-- Begin section -->More code<!-- End section -->
<!-- Begin section -->Code spread out
over two lines<!-- End section -->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end