use strict;
my $str = '#DTS matches
DTSHD
DTSES
DTSX5
DTS5HD
#DTS non-matches
DTSXXX
DTSA
#these two are just exact matches
TRUEHD
ATMOS
#they are found anywhere in the text
ATMOSPHERE
#DD matches
DD+5
DD+$5 #here $ is matched by .?
DD+45
DDP5
#DD non-matches
DD
DDA
DD+4
DDPx4
#EAC matches
EAC345
EAC35
#EAC non-matches
EAC34
';
my $regex = qr/DTS.?(HD|ES|X(?!\D))|TRUEHD|ATMOS|DD(\+|P).?([5-9])|EAC3.?([5-9])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}