package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\r\n]*\R)[^\r\n]*\R?`)
var str = `foo
bar
test
123`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}