package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<product>[^*]+)\*(?<qty>[^,]+),?`)
var str = `30143*1,30144*2,30145*3,30146*5,30147*5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}