#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<Module>^\w+)+\s+(?P<Name>.{1,}(?=Ke|Fi))+(?P<Type>(Kernel|File System))"
Local $sString = "1394ohci     1394 OHCI-совместимый  Kernel" & @CRLF & _
                "3ware        3ware                  Kernel        19.05.2015 3:28:03" & @CRLF & _
                "ACPI         Драйвер Microsoft ACPI Kernel" & @CRLF & _
                "AcpiDev      Драйвер устройств с AC Kernel" & @CRLF & _
                "acpiex       Microsoft ACPIEx Drive Kernel" & @CRLF & _
                "acpipagr     Драйвер агрегатора про Kernel" & @CRLF & _
                "AcpiPmi      Драйвер устройства изм Kernel" & @CRLF & _
                "acpitime     Драйвер ACPI Wake Alar Kernel" & @CRLF & _
                "Acx01000     Acx01000               Kernel" & @CRLF & _
                "ADP80XX      ADP80XX                Kernel        10.04.2015 1:49:48" & @CRLF & _
                "AFD          Драйвер дополнительных Kernel" & @CRLF & _
                "afunix       afunix                 Kernel" & @CRLF & _
                "ahcache      Application Compatibil Kernel" & @CRLF & _
                "amdgpio2     Драйвер GPIO-клиента A Kernel        07.02.2019 14:32:20" & @CRLF & _
                "amdi2c       Служба контроллера I2C Kernel        20.03.2019 9:57:33" & @CRLF & _
                "AmdK8        AMD K8 драйвер процесс Kernel" & @CRLF & _
                "AmdPPM       Драйвер процессора AMD Kernel" & @CRLF & _
                "amdsata      amdsata                Kernel        14.05.2015 17:14:52" & @CRLF & _
                "amdsbs       amdsbs                 Kernel        12.12.2012 2:21:44" & @CRLF & _
                "amdxata      amdxata                Kernel        01.05.2015 5:55:35" & @CRLF & _
                "AppID        Драйвер AppID          Kernel" & @CRLF & _
                "applockerflt Драйвер фильтра Smartl Kernel" & @CRLF & _
                "bindflt      Windows Bind Filter Dr File System" & @CRLF & _
                "bowser       Браузер                File System" & @CRLF & _
                "BtFilter     BtFilter               Kernel        25.01.2019 10:46:26"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")