using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w).*?\1";
string input = @"Outdoors
dog
step
bee
Chessboard
Cookbooks
Professionally
Attractiveness
Uncontrollably
disreputably
Recommendation
Interrogations
Aggressiveness
doublethinks
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}