using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([a-z]+)([^<]+)*(?:>(.*)<\/\1>|\s+\/>)";
string input = @"<a>match only <b>the corresponding</b> tag</a> even if there is other <b> text </b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}