Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
<([a-z]+)([^<]+)*(?:>(.*)<\/\1>|\s+\/>)
/
gm
Input 1
1
New
<a>match only <b>the corresponding</b> tag</a> even if there is other <b> text </b>