#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\]|\"FirewallMatchesActions\":\[\"block\"\]|\"FirewallMatchesActions\":\[\"challengeSolved\"\]|\"FirewallMatchesActions\":\[\"challenge\"\])"
Local $sString = ""WAFFlags":"1"" & @CRLF & _
""FirewallMatchesActions":["log"]" & @CRLF & _
""FirewallMatchesActions":["log","log"]" & @CRLF & _
""FirewallMatchesSources":["firewallRules","waf"]" & @CRLF & _
""FirewallMatchesActions":["block"]" & @CRLF & _
""FirewallMatchesActions":["challengeSolved"]" & @CRLF & _
""FirewallMatchesActions":["challenge"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")