import re
regex = re.compile(r"(\"WAFFlags\":\"1\"|\"FirewallMatchesActions\":\[\"log\"\]|\"FirewallMatchesActions\":\[\"log\",\"log\"\]|\"FirewallMatchesSources\":\[\"firewallRules\",\"waf\"\]|\"FirewallMatchesActions\":\[\"block\"\]|\"FirewallMatchesActions\":\[\"challengeSolved\"\]|\"FirewallMatchesActions\":\[\"challenge\"\])", flags=re.DOTALL)
test_str = ("\"WAFFlags\":\"1\"\n"
"\"FirewallMatchesActions\":[\"log\"]\n"
"\"FirewallMatchesActions\":[\"log\",\"log\"]\n"
"\"FirewallMatchesSources\":[\"firewallRules\",\"waf\"]\n"
"\"FirewallMatchesActions\":[\"block\"]\n"
"\"FirewallMatchesActions\":[\"challengeSolved\"]\n"
"\"FirewallMatchesActions\":[\"challenge\"]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")