package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@\[([a-z\d]+):\+([^\[\]]+)\]`)
var str = `some text @[14cd3:+Seldum Kype] things are going good for @[7f8ef3:+Kerry Williams] so its ok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}