$re = '/^(.*)((\byo\b.*?(cut me:).*))$/ms';
$str = 'Hi
yo keep this here
Keep this here
yo
key match line here cut me:
All of this here should be deleted';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);