using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(?|j\.gifs\.com/([^ /\n]+)\.gif|gifs\.com/gif/([^ /\n]+))";
string input = @"https://gifs.com/gif/gJyM5j
https://j.gifs.com/gJyM5j.gif";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}