// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)https?://(?|j\.gifs\.com/([^ /\n]+)\.gif|gifs\.com/gif/([^ /\n]+))").unwrap();
let string = "https://gifs.com/gif/gJyM5j
https://j.gifs.com/gJyM5j.gif";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}