#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$"
Local $sString = "https://www.linkedin.com/sometext" & @CRLF & _
"https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795" & @CRLF & _
"https://it.linkedin.com/hp/" & @CRLF & _
"https://cy.linkedin.com/hp/" & @CRLF & _
"https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://stackoverflow.com/questions/ask" & @CRLF & _
"google.com" & @CRLF & _
"http://uk.linkedin.com/in/someDodgeAddress" & @CRLF & _
"http://dodge.linkedin.com/in/someDodgeAddress"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")