using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$";
string input = @"https://www.linkedin.com/sometext
https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795
https://it.linkedin.com/hp/
https://cy.linkedin.com/hp/
https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile
http://stackoverflow.com/questions/ask
google.com
http://uk.linkedin.com/in/someDodgeAddress
http://dodge.linkedin.com/in/someDodgeAddress";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}