$re = '/^https:\/\/[a-z]{2,3}\.linkedin\.com\/.*$/im';
$str = 'https://www.linkedin.com/sometext
https://uk.linkedin.com/in/wiliam-ferraciolli-a9a29795
https://it.linkedin.com/hp/
https://cy.linkedin.com/hp/
https://www.linkedin.com/profile/view?id=AAIAABQnNlYBIx8EtS5T1RTUbxHQt5Ww&trk=nav_responsive_tab_profile
http://stackoverflow.com/questions/ask
google.com
http://uk.linkedin.com/in/someDodgeAddress
http://dodge.linkedin.com/in/someDodgeAddress';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);