using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""(?:\\(?:[""\\\/bfnrt]|u[\da-fA-F]{8})|[^""\\])*""$";
string input = @"\uff009ea1
\t
\\
\b
\uff009ea1\t\\\b
\uff009ea1\\\b
""Hello there, 123 !@&^#%! what???''""
""Hello there 123 what""
""Hello there, 123 !@&\t\\\b^#%! what???''""
""Hello there \uff009ea1\t\\\b 123 what""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}