re = /^"(?:\\(?:["\\\/bfnrt]|u[\da-fA-F]{8})|[^"\\])*"$/m
str = '\\uff009ea1
\\t
\\\\
\\b
\\uff009ea1\\t\\\\\\b
\\uff009ea1\\\\\\b
"Hello there, 123 !@&^#%! what???\'\'"
"Hello there 123 what"
"Hello there, 123 !@&\\t\\\\\\b^#%! what???\'\'"
"Hello there \\uff009ea1\\t\\\\\\b 123 what"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end