package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\;]*);`)
var str = `background: red; font-size: 14px; color:white;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}