use strict;
my $str = 'create or replace package body something.pkg_test is';
my $regex = qr/create\sor\sreplace\spackage\sbody\ssomething\.(\S*).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";