#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^https:\/\/([www]|[*]\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&\/\/=].*)?"
Local $sString = "https://google.com" & @CRLF & _
"https://www.google.com" & @CRLF & _
"https://www.google.com/*" & @CRLF & _
"https://*.google.com/" & @CRLF & _
"https://*.google.com/asdasdas/*" & @CRLF & _
"https://*.regex101.com/asdasdas/*" & @CRLF & _
"HTTPS://Lorem.Ipsum.dolor.sit.com/amet/*/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")