using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:dictad|pronunciad)(?:a|o)) por (?:don |doña )?([\w\s]+), juez(?:a?) (?:suplente)?";
string input = @"Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
V-1560-2018 Foja: 1 Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por doña SANDRA JANETT ORELLANA ARAYA, Jueza Suplente del Primer Juzgado de Letras de Vallenar',";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}