package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:(?:dictad|pronunciad)(?:a|o)) por (?:don |doña )?([\w\s]+), juez(?:a?) (?:suplente)?`)
var str = `Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por ARMANDO FREDY PUELLES ROJAS, Juez del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
V-1560-2018 Foja: 1 Dictada por don ARMANDO FREDY PUELLES ROJAS, Juez Suplente del Juzgado de Letras, Garantía, Familia, y del Trabajo de Taltal
Dictada por doña SANDRA JANETT ORELLANA ARAYA, Jueza Suplente del Primer Juzgado de Letras de Vallenar',`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}