import re
regex = re.compile(r"(?=([A-Z]\d{2,4}(?:[A-Z](?!\d{2,4}))?))", flags=re.IGNORECASE)
test_str = ("F328AG560F33\n"
"F328AG560F3\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")