const regex = /(\d\d\/\d\d\/\d\d)\s+-(\d+)\s+(\d+)-\s+(\d+)-\s+(\d+)-\s+(\d+)\s+PB\s+(\d+)\s+(X\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d\\d\\\/\\d\\d\\\/\\d\\d)\\s+-(\\d+)\\s+(\\d+)-\\s+(\\d+)-\\s+(\\d+)-\\s+(\\d+)\\s+PB\\s+(\\d+)\\s+(X\\d+)', '')
const str = `01/23/16 -22 32- 34- 40- 69 PB 19 X4`;
const subst = `$2 $3 $4 $5 $6 $7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);