#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:https?:)?\/\/(?:[\w]+[.][\w]+)+/?)+$"
Local $sString = "http://hk.jkkj.jkk.bjjj" & @CRLF & _
"http://hhhcom/" & @CRLF & _
"//llklklkl.com" & @CRLF & _
"uyiyiiy" & @CRLF & _
"" & @CRLF & _
"((?:https?:)?\/\/[\w\.\-]+/?)+$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")