$re = '/^(\S+\s+\d+\s+\S+)\s*\S*\s*\S*\s*(Failed authentication attempt)\s+\S+\s+\S+\ IP: (\S*)/';
$str = 'Feb 19 15:02:04 domain.ru:log_auth warn Failed authentication attempt (not-authorized) from IP: 1.2.3.4';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);