use strict;
my $str = 'https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/house/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/peter/101149226/162674402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/162688402
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732168/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732163/
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/paymentprocess/101149226/1626884032
https://www.deindesign.de/de/designer/designcases/silikoncase/apple-iphone-6/CT1326#/workspace/91732162/';
my $regex = qr/^.*?\bwww.deindesign.de\/de\/designer\b.*?\workspace\b.*?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}