#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "X-Gmail-Labels\s*:\s*(?P<X_Gmail_Labels>.+)[\r|\n\S\s]+Delivered-To\s*:\s*(?P<delivered_to>.+)[\r|\n\S\s]+Subject\s*:\s*(?P<subject>.+)[\r|\n\S\s]+From\s*:\s*(?P<from>.+)"
Local $sString = "From 1488780641874111180@xxx Mon Dec 29 12:11:00 2014" & @CRLF & _
"X-GM-THRID: 1488780145305309925" & @CRLF & _
"X-Gmail-Labels: Sent,Important" & @CRLF & _
"MIME-Version: 1.0" & @CRLF & _
"Received: by 10.52.29.70 with HTTP; Sun, 28 Dec 2014 16:11:00 -0800 (PST)" & @CRLF & _
"X-Originating-IP: [82.13.144.221]" & @CRLF & _
"In-Reply-To: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>" & @CRLF & _
"References: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>" & @CRLF & _
"Date: Mon, 29 Dec 2014 00:11:00 +0000" & @CRLF & _
"Delivered-To: hello@domain.co" & @CRLF & _
"Message-ID: <CAN8wjQQWm33RS-hDdE1k3c6CMOge9-eq=3GrcNssV8gPYi+osA@mail.gmail.com>" & @CRLF & _
"Subject: Re:" & @CRLF & _
"From: DG <hello@domain.co>" & @CRLF & _
"To: info@otherdomain.us" & @CRLF & _
"Content-Type: multipart/alternative; boundary=001a11c2183a9b3b4e050b4fb549" & @CRLF & _
"--001a11c2183a9b3b4e050b4fb549" & @CRLF & _
"Content-Type: text/plain; charset=UTF-8" & @CRLF & _
"Hey Chris," & @CRLF & _
"Is that price for the pass with tax?" & @CRLF & _
"Also do you have any recommendations for good rental places in town?" & @CRLF & _
"Cheers," & @CRLF & _
"-dave"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")